Deposit Issues for players who reached past their maximum limit

Incident Report for GGPoker.ca

Resolved

This incident has been resolved.
Posted Jan 24, 2024 - 13:38 UTC

Investigating

There is a deposit issue affecting players who require additional verification once they reach their maximum limit.
Posted Jan 24, 2024 - 13:14 UTC
This incident affected: Payment.