Cash game Partial Outage

Incident Report for GGPoker.ca

Resolved

This incident has been resolved.
Posted May 20, 2026 - 14:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2026 - 13:43 UTC

Update

There is an ongoing issue with players failing to join specific stakes in Cash Games (Hold'em, PLO, AoF).
We are currently investigating this issue.
Posted May 20, 2026 - 13:21 UTC

Investigating

We are currently investigating this issue.
Posted May 20, 2026 - 13:19 UTC
This incident affected: Cash Games.